Index ⇒ General Topics ⇒ My Graphics Driver Issue (NEED HELP WITH THIS)

Thoughts on life, the universe and everything else not covered in other categories.

Moderator: LW Moderator

My Graphics Driver Issue (NEED HELP WITH THIS)

Postby Porus » Tue Sep 15, 2020 9:39 pm

Pc Specs:
Laptop Manufacturer: TOSHIBA
Model: Satellite C660-A200 PSC0QV-03C030GAR
CPU: Intel Core i3-380m 2.53 GHz
GPU: Intel HD Graphics Arrandale (Ironlake)
OS: Windows 7 Ultimate SP1 x64
RAM: 2 GB (1.86 GB Usable)

So I recently installed The Penumbra Collection from GOG, started Overture, but after loading the game gives a white screen, I googled it and it said to disable post process effects, I did it and it worked but the game didn't look good, so I messed with the settings, so end result, disabling bloom but leaving all the other post process settings intact would also fix the problem, but I don't want to disable bloom (the only settings I disable/reduce in any games that I play for better performance are shadows, ambient occlusion, motion blur, resolution and occasionally v-sync, all other settings like textures, post fx effects (depth of field, bloom, specular etc) are maxed out, and games run pretty well (10-60 fps). There is another game that was a big problem: ParaWorld

The game's textures used to continuously flash (sometimes the entire screen too), at some specific angles the game would become stable, but would start flashing again, I loved this game but could never play it because of this problem, but when the VERY FIRST time I installed it (4-6 years ago) I remember the screen or textures wouldn't flash, and was going through chapter/mission 4 when my HDD died, and I had no idea what drivers I had installed, so I eventually after getting a new HDD and installing windows (also a few years ago), I got the latest supported drivers for my intel graphics card (generic intel drivers apparently) and since then the ParaWorld flashing problem started, so after months of failed attempts to fix it, I eventually gave up and uninstalled it out of anger.

But today, after the Penumbra graphics problem I decided to install the OEM drivers for my graphics card (took nearly 2 years to find them but found it today through driver identifier) it was version 8.15.10.2281 (modified for my toshiba model I think), so I uninstalled my current graphics drivers (generic v8.15.10.2993), and installed the older OEM one and first thing I did was install ParaWorld and to my surprise, the game worked like a charm, the texture/screen flashing problem was gone and only on rare occasions the flashing happens. I had high hopes for Penumbra - Overture, and the white screen was gone alright, but there is another problem now:
Image
This is what the game looks like now with the OEM drivers.

Now on with the system problem, my graphics card supports DirectX 10.1 and when the generic drivers (8.15.10.2993) were installed my DDI version in dxdiag was 10.1, in the intel control panel it was 10.1 and in the windows experience index it was 10.1, but now with the OEM drivers (8.10.15.2281), it just shows my DirectX version as 10 (10.0) everywhere, intel control panel shows 10.0, dxdiag DDI version is 10, and windows experience index shows it as DirectX 10, I couldn't find any clues on google so I though I'll post it here, because you guys know more about this stuff than I do :). My thoughts are that after I finish paraworld I go back to the generic driver, but what do you guys suggest, should I go back to using the generic drivers or should I stick with this OEM one :huh: (cuz I have a feeling that this driver is gonna cause more problems than fix them) and I have yet to test other games, but my main concerns are ParaWorld, Penumbra and my system not using the highest DX version that it used to. :thanks: in advance

EDIT: I forgot to mention that in windows experience index my scores with the generic drivers were:
Desktop performance with windows aero 3.8
3D business and gaming graphics 5.2

and now with these OEM drivers it is:
Desktop performance with windows aero 3.9
3D business and gaming graphics 5.1
Porus
Super Member
 
Posts: 261
Joined: Sun Mar 31, 2019 3:39 pm
Thanks: 152
Thanked: 48 times in 45 posts

Re: My Graphics Driver Issue (NEED HELP WITH THIS)

Postby Porus » Thu Sep 17, 2020 5:49 pm

I have tried an even older build of the OEM driver, version 8.15.10.2189 and ParaWorld is even more stable than it was in version 8.15.10.2281 :D, but the problem with Penumbra is still there.

NOTE: The reason I didn't post this topic in Games Support is because there are two games that I needed help with (one, ParaWorld is fixed for now), and my system is also not reporting/recognizing the correct version of directx, so I thought this (General Topics) is the best place for this.
Porus
Super Member
 
Posts: 261
Joined: Sun Mar 31, 2019 3:39 pm
Thanks: 152
Thanked: 48 times in 45 posts

Re: My Graphics Driver Issue (NEED HELP WITH THIS)

Postby hfric » Tue Oct 27, 2020 12:01 am

To make some games run on Exotic in-build cards people made graphic wrappers that help emulate missing graphical features . One of the know wrappers is dgVoodoo 2
Code: Select all
http://dege.freeweb.hu/dgVoodoo2/dgVoodoo2.html
... there is also DxWnd
Code: Select all
https://sourceforge.net/projects/dxwnd/
... there is also NVIDIA Inspector
Code: Select all
https://www.guru3d.com/files-details/nvidia-inspector-download.html


Each one helps running games in a world when DX10\DX11\DX12 lost its backward compatibility with old DX 1\2\3\4\5\6\7\8\9\9a\9b\9c\9d ... there is also a workaround for old games you have to install DX9c or Dx9d to have your graphical backward compatibility back with old api dll drivers ...
▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬ஜ۩۞۩ஜ▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
Image
▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬ஜ۩۞۩ஜ▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
User avatar
hfric
3DSL Moderator
 
Posts: 4714
Joined: Sun Jan 09, 2005 2:51 am
Thanks: 117
Thanked: 474 times in 405 posts

The following user would like to thank hfric for this post
Porus

Re: My Graphics Driver Issue (NEED HELP WITH THIS)

Postby hfric » Tue Oct 27, 2020 12:05 am

and by the way Prenumbra games need :
HARDWARE T&L: Yes
PIXEL SHADER: 1.1
VERTEX SHADER: 1.1
DIRECTX VERSION: 9.0c

So install DX9c or DX9d ... if problems still exist use a wrapper like all people do on IntelHD GPU
▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬ஜ۩۞۩ஜ▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
Image
▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬ஜ۩۞۩ஜ▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
User avatar
hfric
3DSL Moderator
 
Posts: 4714
Joined: Sun Jan 09, 2005 2:51 am
Thanks: 117
Thanked: 474 times in 405 posts

The following user would like to thank hfric for this post
Porus

Re: My Graphics Driver Issue (NEED HELP WITH THIS)

Postby Porus » Mon Nov 02, 2020 11:42 pm

I haven't had any luck with the wrappers, but I will keep trying.
But I have to ask you for your help with another issue the I am having :oops:, It is about the graphics, or more specifically, textures, for many games (but the one I need help with is ParaWorld). On my old laptop (Intel Core i3-380m, Intel HD Graphics Arrandale, 2 GB RAM (1.86 GB RAM usable), Windows 7 Ultimate x64), in the graphics control panel I set the texture quality setting to 'Quality', Anisotropic Filtering to 'x16' and Vertex Processing to 'Default', and the textures for many games would become crisp, in Paraworld, this was noticeable on tree leaves, rocks and buildings, and it looked like a game from 2010-2014. But on my new laptop (HP Pavilion dv7-6b55dx Entertainment PC, Intel Core i5-2430M 2.40 GHz, Intel HD Graphics 3000, DDR3-1333 8 GB RAM, Windows 7 Ultimate x64), the settings in the graphics control panel are the same, but the textures look like shit, like the game was indeed made in 2006, the tree leaves are very low res and look pixelated textures that were scaled up, here are the screenshots:
Image
Notice how the leaves look pixelated, on my old laptop they looked realistic but I unfortunately have no screenshots for proof, and I don't have my old laptop anymore.

Here are 4 more screenshots:
Image
The rocks' textures looked more crisp than this on my old laptop
Image
These leaves' textures were a bit more clearer on my old laptop
Image
Image
That palm tree fronds looked way better on my old laptop, all these leaves share one thing in common, all the leaves are pixelated, and this pixelation wasn't present on my old laptop, I don't mean to be rude but, no, I am not lying. no, this is not placebo, I am certain that the textures are not being displayed properly or to their full potential/resoltuion. If anyone is wondering why I even bother with the textures, well it is because 50% of the time I just stared at the trees in this game because they looked beautiful and real, and now I can't even look at them for more than 5 seconds because of this.... issue. :thanks: in advance :)
Porus
Super Member
 
Posts: 261
Joined: Sun Mar 31, 2019 3:39 pm
Thanks: 152
Thanked: 48 times in 45 posts

Re: My Graphics Driver Issue (NEED HELP WITH THIS)

Postby hfric » Tue Nov 03, 2020 4:16 am

it depends on your display drivers if they have texture filtering specific set to a application exe... back in the Nvidia Profile days, people just renamed the main game exe to get better settings for a set engine ... some build theirs own profiles with ENB
Code: Select all
http://enbdev.com/download.html
▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬ஜ۩۞۩ஜ▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
Image
▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬ஜ۩۞۩ஜ▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
User avatar
hfric
3DSL Moderator
 
Posts: 4714
Joined: Sun Jan 09, 2005 2:51 am
Thanks: 117
Thanked: 474 times in 405 posts

The following user would like to thank hfric for this post
Porus

Re: My Graphics Driver Issue (NEED HELP WITH THIS)

Postby Porus » Wed Nov 04, 2020 2:19 am

Thank you so much for all your help :thanks: :hug: :), but sadly ENB didn't help with the textures, as you said, it might indeed be a problem with the driver, since I tried many versions: OEM 8.15.10.2291, OEM 9.17.10.2857 and Generic 9.17.10.4229 (the 9.17.10 versions don't even have all the 3d settings, only anisotropic filtering, v-sync and application optimal mode) but none of them helped, it seems that the Intel HD Graphics 3000 just uses a lower level of either texture quality or texture filtering :(.
Porus
Super Member
 
Posts: 261
Joined: Sun Mar 31, 2019 3:39 pm
Thanks: 152
Thanked: 48 times in 45 posts


Return to General Topics

Who is online

Users browsing this forum: No registered users and 4 guests